DiyMobileAudio.com Car Stereo Forum banner
issue
1-7 of 7 Results
  1. General Car Audio Discussion
    Hi, i really need some help. I have an old Magnat Classic 360. Issue with the amp is channel 1-2 sound and work perfect but channel 3-4 keep frying speakers. Both are set up the same no difference. No the GAIN is not even touched. Changed all the Transistors to new but same thing keeps...
  2. New Member Introduction
    Hey I'm having an issue with my loc unit it is a brand new kicker and all of my amp connections are good but when I turn the car on and everything is powered up all is well until I touch the gain knob on my amp. The subwoofer 15 inch vega starts to hum very loudly constant tone. I tried hooking...
  3. General Car Audio Discussion
    Hey everyone, Wasn't sure where to post this, hope this is okay. I've done a decent amount of installations (upgraded the head unit, front speakers, and installed a sub on my previous car), but have run into an issue I can't seem to fix. I just recently got a different car and wanted to switch...
  4. General Car Audio Discussion
    Hi everyone, My nephew had a sub, amp, and head unit installed by a local car audio shop at the first of the year. His sub quit working completely a few months ago and he asked if I would look at it. I had limited time and no multi-meter, but I could see that the amp was turning on without...
  5. Technical & Advanced Car Audio Discussion
    I recently had to switch back to my stock radio from a VX7020 that I punched a hole into. I'm still using the same amps to run my system and everything works with the stock radio again, however, my speakers can't get as loud as they used to and start fuzzing way before they used to. Any ideas...
  6. Technical & Advanced Car Audio Discussion
    I love this forum, read it all the time... I had 2 pairs of ID xs65 component speakers professionally installed in my front and rear doors. Everything is connected and wired correctly. Two sets are not working correctly. It sounds as if the woofer is only playing high frequencies with no mid...
  7. Technical & Advanced Car Audio Discussion
    Greetings, I recently purchased a 80PRS as an upgrade to my existing Car audio setup. I am having an issue with the CD player function of the head unit. The Cd player function icon is not being displayed in the source selection menu. Also I am unable to insert a CD into the player slot it does...
1-7 of 7 Results
Top