DiyMobileAudio.com Car Stereo Forum banner

no power

  1. Kenwood DDX9903S will not power on

    General Car Audio Discussion
    Hi, I have a Kenwood DDX9903S that has been installed and working for six months. Last night the car battery was disconnected, and on reconnection the head unit will not power back on. There is a red flashing triangle at the left edge of the row of hard buttons that is flashing, but the display...
  2. Is my brand new amp shot?

    General Car Audio Discussion
    Hi Everyone, First post here! I bought a used car a a couple weeks ago and the stock bose amplified system was a mess. I ripped everything out and ran new speaker wire, replaced the speakers, added an amp, and dropped in a sub. Luckily, all the speakers work great; however, I am having trouble...
  3. Having trouble with both new and old HU

    General Car Audio Discussion
    Hi everyone! I'm new to the forum as I'm just getting into car audio and audio in general. I'm fairly familiar with electrical in general and so I thought wiring a new HU in would be no problem at all. I have a 2000 Grand Prix which stock has a very annoying double DIN style head unit. I...
  4. Cannot Get Amp to Power On

    General Car Audio Discussion
    Equipment: Amp - JL2 360.2 (Bridged) Sub - ARC Audio ARC Series 12" (350 RMS; wired to 4ohm) Box - Dual Port 1.25m Enclosure; I am changing the box soon, but including it for general purposes. Problem: I cannot get the amplifier to turn on. I have checked the power, ground and remote wires...
Top