DiyMobileAudio.com Car Stereo Forum banner

61 - 75 of 75 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter #61
Amp got wet, sent to AudioControl to be fixed. Left my friggen rear window open. So, while I wait, I'm reconfiguring the amp and sub area. Right now I'm working on rerouting wires AWAY from that friggen window to the amp panel.

And reconfiguring the amp panel


This was my first carpeting job! Now I'm going to carpet the sub box....

Sent from my 1+7P using Tapatalk
 

·
Registered
Joined
·
306 Posts
Discussion Starter #63
Pro tip: don't carpet sub box after a day of day drinking by the pool

Just waiting to get amp back....


Sent from my 1+7P using Tapatalk
 

·
Registered
Joined
·
87 Posts
There are two activities that I refuse to drink before and during..... Car audio installs/tunes and poker.... Any update on amp getting fixed?
 

·
Registered
Joined
·
306 Posts
Discussion Starter #65
There are two activities that I refuse to drink before and during..... Car audio installs/tunes and poker.... Any update on amp getting fixed?
Hahahahahaha. Yeah.

Both amps are at their respective manufacturer - the arc audio is going in the boy's car. AudioControl says they will turn around as soon as possible, arc says 2-3 weeks.

Sent from my 1+7P using Tapatalk
 

·
Registered
Joined
·
306 Posts
Discussion Starter #67
$85 because not a warranty item. Arc is charging more. Guy I talked to on the phone at AudioControl was like "having a bad week eh? As soon as we get it well turn it around asap".

Then FedEx blew it, and it got there 3 days later than it was scheduled to.

Sent from my 1+7P using Tapatalk
 

·
Registered
Joined
·
87 Posts
That's not too bad considering. Sucks about fed ex, UPS has been the one that has been horrible for me lately.... Keep us posted :)
 

·
Registered
Joined
·
306 Posts
Discussion Starter #69
Still waiting. AudioControl called me on Tuesday to get my payment information, but I haven't heard from them since, and they haven't charged the card yet. Have not heard from Arc at all. Sent a follow up email to both asking for a status. The Arc is going in my son's car.
 

·
Registered
Joined
·
306 Posts
Discussion Starter #70
The Arc has shipped! The AudioControl has not. And with all this idle time, I'm thinking of jumping up to a 12" sub, shallow mount (5" and under) @400w RMS.....
 

·
Registered
Joined
·
306 Posts
Discussion Starter #71
Well, the Arc comes in today, but is going in my son's car. AudioControl contacted me today saying they are waiting on parts still & they are hoping to ship it back next week - so I asked how much more to just swap the amp out with a new one. Haven't heard back.

Mr. Marv is building me a new box - going to put in a 12" JL 12TW3-D8 - going to run that in parallel for a 4ohm load as the AC channels 5/6 are not 2ohm stable
 

·
Registered
Joined
·
306 Posts
Discussion Starter #72
So here's the scoop on audio control. I gave him a call today to find out the status of my amp they let me know that they were waiting on parts. I said if there's an upcharge I'll just take a new amp. They said that's the problem. Covid-19 screwed up their supply chain and they don't even have parts to make new ones. They're waiting on parts for everything.....

Sent from my 1+7P using Tapatalk
 

·
Registered
Joined
·
306 Posts
Discussion Starter #74
Now adding a Dayton Audio DSP-408, and going active up front.

Sent from my 1+7P using Tapatalk
 

·
Registered
Joined
·
306 Posts
Discussion Starter #75
Made a bigger rack to accommodate the amp and dsp. DSP gets here tomorrow, then I'll start disassemble (again) and rewire (again)


Sent from my 1+7P using Tapatalk
 
61 - 75 of 75 Posts
Top