DIYMobileAudio.com Car Stereo Forum banner
1 - 1 of 1 Posts

· Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi everyone this is my first post here on the forum. I would just like to say this now that I apologize for any dumb questions I might ask because it is likely there will be a few. That being said, I'll get started. Firstly, I want to ask if you guys think there was a noticeable problem with the old setup I was running.

One singular Rockford Fosgate Punch P2 10 inch subwoofer (2 ohms) 300 RMS.
JBL GT5-A604 4 channel Amplifier

4 ohms: 60 watts x 4 chan.
2 ohms: 80 watts x 4 chan.
Bridged, 4 ohms: 160 watts x 2 chan.

I had been using this amp for about three years or so. Recently, it started repeatedly blowing fuses. I got it checked out and the gentleman at the audio store said it is likely that the amp has just gone bad since it is a pretty old model. Now comes the present. Today I did some research on what amp to buy next. I decided on purchasing the Alpine MRV-M500. The specs on this amp read:
  • 500W RMS x 1 (2Ω, 14.4V, ≤1% THD+N)
  • 300W RMS x 1 (4Ω, 14.4V, ≤1% THD+N)

Do you guys think this would be a suitable amp for my subwoofer? Also my subwoofer says 1 ohm on the side of it, but everywhere online it says that it is 2 ohm. Lastly, did my previous amplifier have any affect or benefit on my factory speakers? And if so would my new amplifier do the same since it is monoblock?
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top