DiyMobileAudio.com Car Stereo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #1
My trusty CDA-7998 has finally succumbed to the dreaded "Blank Display"
disorder.
The local Alpine repair center has no parts & no support available (No Surprise)
Anyone out there have any resources to help me get this venerable head unit
back into working order?
Thanks to any and all.............
 

·
Registered
Joined
·
26 Posts
I'm trying to find where I sent mine off to. It was a long time ago, and about the only thing I remember was that it was a lot more than I really wanted to pay. (IIR around $200+) But... it's still working to this day.
 

·
Premium Member
Joined
·
1,775 Posts

·
Premium Member
Joined
·
1,775 Posts
looks to be discontinued
Ah, sorry. Had the link saved for reference a while back, last time I was there it was available.
 

·
Registered
Joined
·
4,102 Posts
It depends on if it's the internals in the face or something else.


Do you know what is wrong?

I almost bought one off here early this year but my repairman who works for alpine and pioneer has no more internal screen parts.

It might be toast unless it's the ribbon.


I didn't look at that eBay link but if it's a new face then you might snatch it unless it's too much money
 

·
Registered
Joined
·
209 Posts
Discussion Starter #8
It's one of those situations where, I'd love to get the screen, but I've had far too much experience with Murphy's Law. Chances are, I'd end up with a functional screen, and a
dead, unobtainable LSI somewhere else in the unit. Christmas is for the kids, not for their Dad.......................
Thanks for the input!
 
1 - 9 of 9 Posts
Top