DiyMobileAudio.com Car Stereo Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
So i apparently broke the iPod cord that came with my iDA-x305s and since this cannot be replaced with any cable not alpine im forced to shell out the 30 bucks for a new one. When looking on the site i came across a "Full speed" cable which instead of using USB it uses what i think is the "Ai-net" plug on the back of the HU, so my question is this. What does "full speed" mean? The stock usb cable combined with my head unit was pretty damn fast. So would it be worth the upgrade?
 

·
Registered
Joined
·
1,043 Posts
If nobody answers, try crutchfield or best buy chat
 

·
Registered
Joined
·
154 Posts
I'm confused, why can't you use a regular usb cable? I used a oem Apple ipod cable with my IDA-X200. Looking at the manual for the 305S it looks like its just a regular USB as well.
 

·
Registered
Joined
·
154 Posts
I don't know what to tell you man. I would say pop it out of the dash if you haven't already and check your USB connections. It's possible you damaged the socket on the headunit. It's just a simple USB cable as far as I know, I amp pretty sure the only difference is that the Alpine version has the set screw to help hold it in place.
 

·
Registered
Joined
·
2,803 Posts
not all of the ida line will work with the apple version of the usb cable. i had a 100 and 001 and neither would work without using the supplied alpine cable.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #7 ·
Yea alpine is all about the extra stuff to buy for their unit. Kinda wish I would have gone with the pioneer unit I was looking at sometimes. I'll try using a USB extension cord with the alpine iPod adapter
 
1 - 7 of 7 Posts
Top