DIYMobileAudio.com Car Stereo Forum banner
1 - 11 of 11 Posts

· Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
So I just installed a 320amp alternator in my 2007 saturn vue. I was expecting my warning lights to come after installation (which they did). So I tested the battery with the car off and it read at slightly over 12v. Then started it and tested at the battery and the alternator, both read at 15.33v. The voltage didn't change whether at an idle or bumping the tachometer up to 3 grand. I've never had a high output alternator of this size and I'm concerned with the higher voltage damaging the electrical system. I did the big 3 with sky-high audio 1/0 ofc. The grounds all tested good on the dmm. Is the higher voltage normal with higher output alternators normal or am I risking something failing leaving it installed?
 

· Registered
Joined
·
4,298 Posts
I checked it again when I got to work this morning. After warming up the voltage read at 14.8
That's still a bit high but safe, 15.33 volts is too high.
 

· Registered
Joined
·
395 Posts
what brand did you go with?
did it come with a verification report (can't think of the proper name ATM)

I don't know what the limits are of a vehicle. My semi's stock alternator charges at 14.8-15+ volts depending on if the batteries are low. It's only a 12v system. I think newer cars charge in the mid to upper 14v range but I could be mistaken.

I would definitely call the place you bought it from or the manufacturer to verify.
 

· Registered
Joined
·
72 Posts
Discussion Starter · #8 ·
Most high output alternator charge at 15v
So the15.3v is ok when cold? It does drop to 14.6 to 14.9 after the engine has warmed up

I got it from J&S I don't recall seeing a verification report but the stock alternator died before my install appointment (was gonna have everything installed when my new sub box was ready). The install was last minute with me trying to get to work, so I mainly checked for any special install instructions and got it in tbh.
 

· Registered
2014 VW CC Sport
Joined
·
1,794 Posts
So the15.3v is ok when cold? It does drop to 14.6 to 14.9 after the engine has warmed up

I got it from J&S I don't recall seeing a verification report but the stock alternator died before my install appointment (was gonna have everything installed when my new sub box was ready). The install was last minute with me trying to get to work, so I mainly checked for any special install instructions and got it in tbh.
Yes. I also run a 370 amp js alternator. That is normal.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top