DiyMobileAudio.com Car Stereo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i recently installed some jl xr650 components in the front and coax in rear of my pickup. i hooked them up to my eclipse EA4000 amp and everything was hunky dorey for the first 4-5 hrs in it.
i had it up pretty loud for about 5 mins last night and then all of a sudden scratching and screaming noises and no more sound.
checked it over this morning, pulled on the wires and the ground came out. ok put it back tightened it all again-nothing loose now, and worked again for about 10 minutes of driving. hit some bumps and cut out-squealing noise a bit, kept working, them couple more bumps-same thing- scratching and screaming and no more sound. connections tight but no power to amp. wtf

anyone know whats going on? could it be my deck? W505... but pretty sure its the amp. oh btw the amp was brand new when i installed it.

Any help appreciated.
Thanks!
 

·
Registered
Joined
·
6,376 Posts
Hit bumps...you still have a bad connection or maybe a speaker wire grounding.
 

·
Registered
Joined
·
7,406 Posts
Every connection, front to rear, check them... Sounds like maybe a speaker is shorting to the door or something...

start with the easiest things first, work toward the harder..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
so pretty sure its just a connection grounding out then??
ill check er over good

didnt really feel like pulling the door panels again :(
 

·
Registered
Joined
·
7,406 Posts
so pretty sure its just a connection grounding out then??
ill check er over good

didnt really feel like pulling the door panels again :(
I'm not sure of anything, man, i'm not there, but, it surely "sounds" like a connection issue... it's now a matter of which one..

Like I said, start with the easiest connections, and make sure they are all solid, clean and tight... then move toward the more difficult ones..

Troubleshooting is a process of elimination.. start with the easy, work toward the hard..
 

·
Banned
Joined
·
2,071 Posts
well, with any luck, you can salvage your equipment and get the job done. If you don't take these things seriously, you can injure yourself or others, destory your car and all your equipment. Plus, direct current to ANY speker can be bad....I'd redo EVERYTHING. There is a chance you will have learned this lesson without loss.
 
1 - 6 of 6 Posts
Top