DiyMobileAudio.com Car Stereo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I posted in the MS-8 thread for help but am posting here too for visibility.

Some aspect of my MS-8 crapped out. I'm going to assume it's the display itself since the processor technically works and responds to the remote, but the display doesn't work.
Of course it crapped out mid tune and left me with only two channels processing, and it's the left and right tweets only . There's no point in listening to music on just two tweets.

Does anyone have a display local to Philadelphia that I can meet up to test? Anyone have a display that I can pay to ship and borrow for testing? If it turns out my display is bad I'll buy one off eBay, but I don't want to shell out ~$150 for an eBay display if the issue lies elsewhere.

Sent from my GM1915 using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Try loosening the 4 screws that hold the front and back together this may help as it did with my display.
I have it a shot but no dice every with the screws fully loosened the symptoms persist.

Sent from my GM1915 using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I have it a shot but no dice every with the screws fully loosened the symptoms persist.

Sent from my GM1915 using Tapatalk
Ugh I'm such a dope.

I fixed it. The unit was responding to the remote so I opened up the manual, found out where Reset Defaults was in the manual, and clicked the arrows until I got it. The unit reset and the display works!

Now, could anyone share the calibration disc audio file, pretty please?

Sent from my GM1915 using Tapatalk
 

·
Registered
Joined
·
106 Posts
Ugh I'm such a dope.

I fixed it. The unit was responding to the remote so I opened up the manual, found out where Reset Defaults was in the manual, and clicked the arrows until I got it. The unit reset and the display works!

Now, could anyone share the calibration disc audio file, pretty please?

Sent from my GM1915 using Tapatalk
Out of interest Zapps what page is the reset procedure on in the manual ?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6 (Edited)
Out of interest Zapps what page is the reset procedure on in the manual ?
Press the menu button a bunch to be sure that I'm at the home screen. Then press the down arrow 4 x followed by center button. Then press the down arrow 6 x followed by center button.

It's pages 35 and 36 in the manual. Screenshot_20191204-174920.jpg Screenshot_20191204-174932.jpg

Also, shout out to @FordEscape for having the MS-8 calibration .wav file!


Sent from my GM1915 using Tapatalk
 
1 - 6 of 6 Posts
Top