DiyMobileAudio.com Car Stereo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
What do you guys think the best double din is out there? Definitely looking for the more audio quality aspects in my head unit. I'm a fan of eclipse for this reason but don't have too much experience with other makes.
 

·
Registered
Joined
·
933 Posts
Ive only run Alpine DD's in my personal rides, but working in a shop that carries Sony, Pio, Alpine, Kenwood, Clarion, and some cheap ****, i must say that the Kenwoods have really stepped up their game. Great features, quality, and system layout.

I only keep my alpine since it works so well with my H701. If i didnt have that i would run one of the new kenwood nav units
 

·
Registered
Joined
·
210 Posts
sold kenwood at the shop and their new line up all built in features really make installion easy and the interface is great to work with.
cant really beat the excelon units
 

·
Registered
Joined
·
323 Posts
kenwood excelon units are awesome except for some lag

if you can wait more than 2 seconds do the Kenwood
 

·
Registered
Joined
·
2,749 Posts
Out of the box: Pioneer, best ipod integration, best bluetooth phonebook, good EQ (8 band, most only have 5-7), excellent picture quality, good VFM.

Otherwise Alpine if you want to add processors for ultimate SQ

Kenwood-personally HATE the Garmin Nav, otherwise ipod integration slow comp to pioneer and while GUI looks cool I find it a PITA

Clarion-new NX501E is lovely to look at, great GUI graphics-though haven't played with it much and the navi is 3rd party cheapo-but seems ok

Sony-weak effort, ipod terrible, nav is TomTom-ok if you like it, good display, reasonable audio features though the ipod integration has put me off playing too deeply with these units.
 

·
Registered
Joined
·
42 Posts
yes kenwood has the best gps of them all imo but lacks in the touchscreen side, also when starting up the unit takes for ever to load up, the eq and functions are ther but is a bit slow even through menus. keep in mind i had most of all the high end units, the alpine i believe has the best picture is just brilliant, but lacks in the eq section, gps is ok but not better than garmin of the kenwood, the touchscreen is spot on and quick even through menus. pioneer i think is my favorite although i wish it had the garmin, the gps is ok but again not better than the kenwood, the eq's on it are great the unit starts up just in time, bluetooth is right on, the touchscreen is pretty quick and going through menus is quick also.
 

·
Registered
Joined
·
2,749 Posts
I can't get everyones love of the garmin-maybe we get something different here but I find it awful to use:

Pioneer you can put up 14(IIRC) destinations in and hit "sort" and it'll put them into the shortest route-garmin I've not found how to put a waypoint in let alone 12 other destinations.

Pioneer shows you 2 turns ahead what you're doing, has enough detail on the screen to glance at it and know exactly what's going on-garmin looks like a kindergarten doodle...
 

·
Inappropriate Thoughts
Joined
·
4,005 Posts
I would do the Alpine with Imprint and manually tune it. Otherwise, I would be looking at a hefty price tag for just about any other double-din HU because of the separate processor needed to stay active with time alignment. Sorry, but after experiencing the age of digital processing, I find it hard to revert back to 80s technology.
 

·
Registered
Joined
·
161 Posts
I just got a Pioneer FH-P8000BT and the radio is very nice and has 3x6v pres. That being said, it's 100% useless with my iPhone. I'll be selling it soon and getting something that will work with my phone. Not sure why so many manufacturers have trouble with this.
 

·
Registered
Joined
·
211 Posts
I love my Sony 770bt.

There are only two things about it I dont like.

1. Sometimes, when listening to the radio and you go to turn of your car, it will switch stations. You can hear it happen for a split second. Turn your car on and its not where it was before.

2. GPS. Tomtom has issues with GPS connectivity after awhile. Its a known issue and everyone rants about it on tomtom forums. Mine worked fine for 3 months I had it in till last week where it couldnt get a signal no matter what. I updated it and so far its been working okay.
 
1 - 16 of 16 Posts
Top