DIYMobileAudio.com Car Stereo Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
895 Posts
Discussion Starter · #1 ·
On a lark I decided to update my director which is < 1 year old. If it matters, its a new to me laptop with a fresh Windows 10 install.
Downloaded the latest 2.77 director updater, installed all the drivers, rebooted etc.
Plugged the director into the PC, and put the director into update mode and launched the updater. Chose my DSP and clicked upload.

Got an error message back, some kind of obscure code error. I can go out to the laptop repeat and write it down but I don't think that's going to help now.
Clicked through and update says its complete.

Since that error, the Director is dead, no screen no nothing. I've tried cycling power, doing the update again (get the same error). Trying to start the DSP software it just goes to demo mode (no connection).

And worst of all, of course, no music playing. I realize I can (hopefully !) go into the DSP directly and turn off the director control and that should allow music to play, but I need that volume control up front so that won't help me much.

Any thoughts on how to wake/reset this thing back up ? Am I really SOL because I tried to use Helix software to update my Helix product ?
Obviously I'm going to call MSC in the morning but just wondering if anyone had any ideas.
 

· Registered
Joined
·
895 Posts
Discussion Starter · #3 ·
Well just my luck - the number for MSC is disconnected. I just called them on the 27th about a separate issue on a different Director so this is a recent development. Hopefully its temporary, I'll try their email and may email Germany as well. Quite dismaying, as these things seem to be thin on the ground right now not that I'm eager to purchase a new one anyway. Also super annoying that I can't just put in a Conductor but evidently my fancy schmancy Pro Mark 2 doesn't support one which is the stupidest thing I've ever heard.
 

· Banned
Joined
·
24,246 Posts
Also super annoying that I can't just put in a Conductor but evidently my fancy schmancy Pro Mark 2 doesn't support one which is the stupidest thing I've ever heard.
This is a hardware problem. The pro mk2 doesn't have the hardware to support the conductor. Not very stupid. It just is what it is. Sorry that your director isn't working. Shoot me an email and I'll see if I can dig up the info for what someone else needed to do when this happened.
 

· Registered
Joined
·
895 Posts
Discussion Starter · #5 ·
Thanks for the replies guys. I was able to get a hold of Jason at MSC America and he provided the following procedure:

  • Disconnect the Mini Din side from the processor leaving only +12V and ground
  • Press and hold the volume knob on the director down for 30 seconds
  • Disconnect power from the director and leave disconnected for 10 seconds
  • Plug power back in
  • Attach the USB from the director to the computer
  • Launch the director updater software
  • Select the processor
  • When it says put the director in update mode, click ok. The screen will still be off.
  • The update should start
  • If it completes without any errors, press the power button and the director should turn on

Unfortunately I would still get an error from the Director Update software and the unit was still dead.

Now, this whole debacle started when my old laptop died - it blue screened one me and then would kind of boot up but then the mouse wouldn't work or it would lock up.
I bought a new laptop and downloaded the DSP tool and I figured what the heck there is a new Director update.

After talking with Jason and searching around some threads a little bit, it turns out the root of the problem is the usual Windows/low level driver problems that will tear your hair out. Evidently some recent windows update is a problem, or I did find a low level error regarding my FTDI driver chip that had really obscure and difficult solutions on the internet.

So at this point I was desperate after investing 4-5 hours in trying to save my Director (new ones are $500 retail now !!!!!). I was searching around for my kids 10 year old laptop that was abandoned long ago when my eye fell on my old laptop with its known good Director Update software. I booted it up and lo and behold it was working again although who knows for how long.

I was able to keep it running long enough to update the Director and it came back to life ! I was still freaking out because I wasn't getting any music but I had to remember to turn up not just master volume but also the digital volume AND switch the source in the director to digital coax input (for my setup obviously) because I don't have auto-detect source turned on in the DSP.

So a little lark to "update my Director" turned into a 6 hour ordeal of stress - I already have one Director with a flaky touch screen that needs to be replaced, I can't afford 2, and neither of my DSP's will accept the Conductor, although I think in my truck I will just replace it with the URC.

Anyway my advice to you is

DO NOT UPDATE YOUR DIRECTOR !!!

(until such a time as Audiotec-Fisher can guarantee the driver/software problems are resolved.)

Thanks to Jason and Nick at Apicella for advice and support working through this.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top