DiyMobileAudio.com Car Stereo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
A few weeks ago, my Sony Xplod CDX-838 10 disc CD changer quit working mid-song while I was driving down the road. I restarted my HU and it told me to "reset" my changer.. I have reset my HU ~5 times, and checked all my wiring. (The changer runs to my XDP-4000X processor by a BUS cable and Optical input).

I live in Idaho and this happened on our first morning of 0 degree weather, but it still hasn't worked, regardless of the temperature. I cannot get it to even eject the magazine, and there is no reset button on the changer.

I toyed around with the wiring again today, but my HU either read "hit reset" or "no magazine".. I am stumped as to why it is not working, so I could use any advice!
 

·
Registered
Joined
·
115 Posts
The problem can be some sensor inside of the cd-changer are not 100% !
Cd-magazine cant "read" or find the magazine.

This typical for Sony cd-magazine, have remember that simlar problem to my older Sony changer.

When this happen will the message in headunit display say :

*Push Reset*
*No Magazine*

In this case most the changer to Sony service to fix it. ;(
 

·
Registered
Joined
·
190 Posts
Discussion Starter #3
Sorry for a slow response, I've been busy with a lot of things lately. You're the bearer of bad news I see.... :worried: Do you have any ideas or suggestions of what I could try with this changer to at least make it eject the mag? Right now I would just love to have my CD's back, then I could try and fix it from there.. Thanks for your help though, I appreciate it! :)
 

·
Registered
Joined
·
190 Posts
Discussion Starter #4
I finally got a few hours of free time yesterday, so I jumped on trying to solve the problem with the changer. A buddy and I opened up the casing, and we noticed that one of the changer's trays had jammed in the reader. After carefully pulling out the magazine, we found that the rail that guides the tray in had been bent out of shape. It was easy to realign the rail, and the only other issue was a loose spring that attached to the top piece of the case, which was easy to slide back into the groove. And it is back to being fully functional now!

I forgot to take pictures, but if anyone has this problem, I would have no problem opening mine back up to point it out!
 

·
Registered
Joined
·
115 Posts
OK.. good to hear.

If I remember right , so had also the same "problem" with my CDX-828 some years ago..!

Now use I CDX-91 changer...

I think the best cd-changer from Sony is from the good days :

XES-C1
CDX-91
CDX-U606
 
1 - 5 of 5 Posts
Top