DiyMobileAudio.com Car Stereo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Ok guys I need some help with this..So im running 4 morel tempo ultras and right now just 2 tweeters and oushing those is a 4ch zapco st-04x P 480 RMS..now the morels are 120rms 250 peak..but i also have a dsp that im wanting to incorporate into this build..so since i only have 4 ch amp im wanting my 4 speakers to be tied with each channel so that leaves my focal tweets without any coverage..so my only option would be to use the component crossovers that came with the focalks or with the morels but since im jus wanting to cross the tweets i was gonna use focals passive xover..but with the dsp meaning go active correct so how shoulkd i instead have everything wired..Heres my thinking but i dont kno very much in ways of wiring systems i kno enough to get it done on a very basic level..But i was jus gonna use the morel component xovers with all 4 speakers and then tie the two tweets up front into those and be done..again those are passive crossovers and im trying to understand by going active what that entails entirely..sry for the confusion im just really wanting the best sq i can get and i dont wanna have to go back and redo it all because i was afraid to seek advice..So i appreciate anyone tthat can point me in the right direction..thx
 

·
Registered
Joined
·
507 Posts
That is a lot to unpack.

Start by telling us a little bit more about your four Morel speakers. Are they coaxial or are they the mid Bass from a component set? Are you running a pair up front and then a pair of the back for rear fill?

based on what you've written I assume that they are the mid Bass from a component sit and you still have the Crossovers that came with him. Likewise you seem to still have the crossover for your Focal tweeter.

Based on what I've been able to glean from your post I think you need another two channels of amplifier power. Or you need to run a passive system. Perhaps you could run the Morels parallel for a 2 ohm load on the first pair of amplifier channels and then run the tweeters on the second pair?

Sent from my Pixel XL using Tapatalk
 
1 - 2 of 2 Posts
Top