DiyMobileAudio.com Car Stereo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have all the parts (just waiting for the weekend to install), but wanted to know everyone's opinion. AMPs are XD600/6 & RD500/1

Should I:
A. Amp-Pro Remote out > DSP (remote out) > both AMPs.
Or
B. Amp-Pro Remote out > Relay > DSP & AMPs?

Oh, and in case B is the best choice, would there be a reason to do the remote out to the DSP first, then use that remote to turn on the Relay first and let the relay turn on the AMPs?

I realize I'm likely splitting hairs on how to do this, but I honestly don't know what would be considered best practice, so it's worth asking.

Thanks!
 

·
Registered
Joined
·
3,675 Posts
All depends on what kind of DSP your using. If you using Helix, I would strongly recommend to use one.

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
17,754 Posts
All depends on what kind of DSP your using. If you using Helix, I would strongly recommend to use one.

Sent from my Pixel 4 XL using Tapatalk
We have used the helix to turn on 7 amps before... 2 will be zero problem

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
3,675 Posts
We have used the helix to turn on 7 amps before... 2 will be zero problem

Sent from my SM-G975U using Tapatalk
I agree with you.
That's not the problem here, im more worried about pop noise from Helix. With relay you get a delay so the pop noise is eliminated.

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
3,675 Posts
Im running 3 amplifiers in my car and don't have the issue because of an relay. Without that I would get pops non stop. Took out one of my tweeters.. but hey what do I know :)

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
17,754 Posts
I agree with you.
That's not the problem here, im more worried about pop noise from Helix. With relay you get a delay so the pop noise is eliminated.

Sent from my Pixel 4 XL using Tapatalk
You dont get delay from a standard relay. You do with something like a TR7. But also, that's not needed. The helix has remote out on/off delay.

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
3,675 Posts
You dont get delay from a standard relay. You do with something like a TR7. But also, that's not needed. The helix has remote out on/off delay.

Sent from my SM-G975U using Tapatalk
That is correct and I still had the pop issue no matter what. OP could do what he wants, im just stating my opinion and what I have faced as a problem that's all.

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
3,675 Posts
I know that you, and many others really need to start reading your damn manuals

Sent from my SM-G975U using Tapatalk
I do read them more often than I should :)...

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
17,754 Posts
That is correct and I still had the pop issue no matter what. OP could do what he wants, im just stating my opinion and what I have faced as a problem that's all.

Sent from my Pixel 4 XL using Tapatalk
Then the delay or lack thereof isnt your problem

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
3,675 Posts
Ahh Skizer you never gonna be nice are you. It's ok I was trying to help out OP not you..
Thanks for your effort..

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #14
No need to argue guys, but from the responses, I will do the TWK-88 remote out to turn on the AMPs.

And if I hear a snap, crackle, or pop - I was warned 😅
 

·
Registered
Joined
·
3,675 Posts
No need to argue guys, but from the responses, I will do the TWK-88 remote out to turn on the AMPs.

And if I hear a snap, crackle, or pop - I was warned
That's awesome, you didn't mention that in the begining lol.
We could have avoid Skizer getting all up and worried lol.
Me and Skizer have a long history together it's a love hate relationship..

I still thinks he's a cool mofo, regardless of what others say about him. I respect him as a person, and as a friend but I guess he doesn't see that. Maybe one day he will realize that others do care and have feelings too :). Either way good luck with your install hope all your questions were answered lol

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
17,754 Posts
Ahh Skizer you never gonna be nice are you. It's ok I was trying to help out OP not you..
Thanks for your effort..

Sent from my Pixel 4 XL using Tapatalk
I think you're misunderstanding my tone here, or are trying to spin this on purpose. I'm just trying to explain that lack of delay is not the problem in your system and i think that was kinda obvious after you said "applying delay in the software didnt fix my problem". I am only trying to clear up misinformation. Maybe you have it wired wrong, maybe your amps are pulling a lot of current on the remote in, who knows. But all im trying to do is to get the facts straight so the OP isnt more confused by the time he gets back to working on his car.
 

·
Registered
Joined
·
3,675 Posts
I understand we both try to help him. Hope he learned something from this. He's not using Helix so he should be fine.



Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
17,754 Posts
I understand we both try to help him. Hope he learned something from this. He's not using Helix so he should be fine.



Sent from my Pixel 4 XL using Tapatalk
That has literally nothing to do with it..

idk why i even waste my time anymore
 

·
Registered
Joined
·
3,675 Posts
LoLz you got me laughing ;) have a good night buddy !

Sent from my Pixel 4 XL using Tapatalk
 
1 - 19 of 19 Posts
Top