DiyMobileAudio.com Car Stereo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I have an IXA-W407 and the Bluetooth is barely functional. It doesn't fully connect until a call is dialed from the phone. I have tried updating the firmware and to no effect it does the same thing. Had the same problem with a Moto Droid and HTC Rezound.

The main thing I like about this unit is the Imprint module I have hooked up. Sounds great, but I am tired of the flaky bluetooth. Can someone recommend another stereo that has SQ ability with TA, PEQ and crossovers that has a reliable bluetooth capability? Double Din preferred, but single would be fine.
 

·
Registered
Joined
·
2,777 Posts
Kenwood X994/X995 works. The BT system is actually quite eager to extent of being annoying. It connects to the phone as soon as stereo is turned on, and greets you with "downloading" message about 20-30 seconds later, bumping you out of 5 levels deep menu system if you were trying to do something with the stereo... After that, the BT system is armed and ready.
 

·
Registered
Joined
·
126 Posts
Another vote for the Kenwood X995, works very well, as does the Kenwood X695. I use an Android Phone.
 

·
Registered
Joined
·
783 Posts
My X993 worked great with both my Blackberry and Android phones. So, another vote for Kenwood. The length of time it takes to Sync depends on your contact list.

Sent from my DROIDX using Tapatalk
 

·
Registered
Joined
·
186 Posts
We recently installed the Alipine W910 in my wife's car and the Bluetooth works great on it. No glitches at all that I've found and the call quality is as good, or better, than the handset itself. Plus, if you are using imprint via the H-100 module it is compatible with the 910.

Crutchfield had it for like $999.00 on sale not too long ago, not sure if it is still going for that price or not.

-Ben
 
1 - 8 of 8 Posts
Top