DiyMobileAudio.com Car Stereo Forum banner

261 - 280 of 340 Posts

·
Registered
Joined
·
1,250 Posts
I will be doing a few of these in upcoming builds Ferrari 458 Italia and dodge challenger.
 

·
Registered
Joined
·
63 Posts
I have now decided to go with Audison amps for class A power. So now I will be using the Helix DSP Pro instead of the P Six. I've put it on eBay if anyone interested in placing an offer. I just got it barely 2 weeks ago.
 

·
Registered
Joined
·
5,675 Posts
Discussion Starter #263
I will be doing a few of these in upcoming builds Ferrari 458 Italia and dodge challenger.
You just said Ferrari and Dodge in the same sentence. What is this world coming to!?!?! :D
 

·
Premium Member
Joined
·
659 Posts
I have now decided to go with Audison amps for class A power. So now I will be using the Helix DSP Pro instead of the P Six. I've put it on eBay if anyone interested in placing an offer. I just got it barely 2 weeks ago.
I've got Audison in my car....and the Helix in my truck. Very comparable amps IMHO
 

·
Registered
Joined
·
1,250 Posts
You just said Ferrari and Dodge in the same sentence. What is this world coming to!?!?! :D
Yep thats right, both ends of the spectrum. lol. I'm more of a muscle car guy for sure.
 

·
Registered
Joined
·
1,250 Posts
The P Six DSP MK2 9.84" X 6.46" X 1.73" (L x W x H) 120w x 6 230w @ 2ohm $1299.95
The SPXL1000 16.93" X 9.84" X 2.16" (L x W x H) [email protected] [email protected] [email protected] $999.95

The SPXL1000 is 7.09" longer 3.5" wider and .19" taller then the P-Six MK2, not to bad for a 1600 watt amplifier.
 

·
Registered
Joined
·
518 Posts
We're using a Helix B One for sub duties in a friends car, with a P six to power the 3-ways up front + control the B One. Well, still waiting for the P six to arrive, but the rest is installed. The P six has about the same (combined) output power as the B One, so they should be able to make a 1/2 channel amp with about 1kw in that same size. Especially when you look at the prototypes for the microsized Match line amps from Helix.
 

·
Registered
Joined
·
1,250 Posts
Update to the Helix P SIX DSP model is now Helix P SIX DSP MK2
From Helix:

Due to unexpected supply difficulties of an essential component and after careful consideration we decided to change the amplifier IC of the device. For this reason some parameters of the technical specifications changed and the device got slight modifications.
The main difference is that the “Class Ultra D” amplifier concept is replaced by the “Ultra HD Class D” technology. This technology allows a 96 kHz sampling rate and an extended audio bandwith of more than 40 kHz. Additionally the P SIX DSP MK2 is now 24V compatible.
Other features and the product design remain the same.
 

·
Premium Member
Joined
·
13 Posts
Update to the Helix P SIX DSP model is now Helix P SIX DSP MK2
From Helix:

Due to unexpected supply difficulties of an essential component and after careful consideration we decided to change the amplifier IC of the device. For this reason some parameters of the technical specifications changed and the device got slight modifications.
The main difference is that the “Class Ultra D” amplifier concept is replaced by the “Ultra HD Class D” technology. This technology allows a 96 kHz sampling rate and an extended audio bandwith of more than 40 kHz. Additionally the P SIX DSP MK2 is now 24V compatible.
Other features and the product design remain the same.
One of the first to have the PSIX installed and mine still works fantastic! Paired with Micro Precision 7 series and a Brax Matrix 10.1 is a thing of beauty!
 

·
Premium Member
Joined
·
1,163 Posts
Trying to install mine..
Manual says when clipping a Red LED should come on. Mine is green as soon as it comes on. I cannot get it to turn red. I am giving it a 1khz at -3db max volum on h/u. I have tried moving the jumpers around.
Any advice?
 

·
Registered
Joined
·
5,675 Posts
Discussion Starter #272
Trying to install mine..
Manual says when clipping a Red LED should come on. Mine is green as soon as it comes on. I cannot get it to turn red. I am giving it a 1khz at -3db max volum on h/u. I have tried moving the jumpers around.
Any advice?

Are you trying to get it to clip? You may not have enough head unit juice. Is the output strong and clean? If so I wouldn't sweat it.


Sent from iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,163 Posts
Yeah... And wasn't sure if the green light was supposed to stay on. Not sure about output yet. This was my first setup step and step and have been hung on this step far too long. Two of my output channels didn't have the threaded inserts for tightening (go figure). Was able to scrounge up 2 then finally just had to go to Home Depot to find something suitable.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
643 Posts
I never got mine to clip either. It is currently mated with a pioneer 80PRS. "It's the little engine that could lol." :D

I wouldn't sweat it Sir.
 

·
Premium Member
Joined
·
1,163 Posts
I never got mine to clip either. It is currently mated with a pioneer 80PRS. "It's the little engine that could lol." :D



I wouldn't sweat it Sir.

Mine is going to a stock h/u. After posting last night I moved forward. Everything seems to be working great. Did a very quick, dirty tune last night and can already tell it's going to sound way better than my previous install.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,163 Posts
Are you sure you're looking at the right LED? From memory the setup selected is Green/Orange (Preset 1/2) and the clipping LED only lights up red when clipping??

If I remember correctly...

Yep I was looking at the correct LED. Either you are misremembering or yours was different. The manual states a red LED will come on when clipping and never mentions a green LED for clipping. However, my unit has a green LED that stays on and that LED is directly under the word "Clip".


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,163 Posts
No sir. Scan R3004, Scan 10f, ID x69, SI MKIV. Subs are ran off Alpine PDX M12. The tweets and mids are mounted in pods from the German fellow.

So far my only complaint is the High level speaker input system they use. That could most definitely be made a lot better.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,163 Posts
So this question isn't specific to the P-Six but didn't want to create a new thread just for this question...

This is my first attempt at tuning, I am using my computer w/ REW connected via aux to my OEM H/U to measure. I am using the sweeps method. How do I account for the volume setting on my computer?

What I mean is, I finished my first tune and it sounded pretty good but there wasn't enough volume. I realized that my computer volume setting was nearly maxed, so I went back and tried remeasuring at a much lower volume setting on my computer but same volume setting on my h/u and sure enough the sweep was at a much lower volume.

The only thing I can think to do, is set the h/u to a particular volume setting and take an SPL measurement with Helix at its stock setting. Then connect the computer and determine what volume setting the computer has to be at to give me the same SPL measurement, with the same H/U volume setting.

Am I missing something really simple?
 
261 - 280 of 340 Posts
Top