DiyMobileAudio.com Car Stereo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello. My problem is my stereo will play normal volume on AM and CD but FM1 and FM2 has very low volume. I can only hear it a little if the volume is on max.

This stereo is in my 2005 Pontiac G6. Its a stock stereo, I think Delphi.

I cant seem to find any info about this anywhere and I just came across this site. Sorry if this is not the right place for this. Thanks!
 

·
Registered
Joined
·
219 Posts
Hello. My problem is my stereo will play normal volume on AM and CD but FM1 and FM2 has very low volume. I can only hear it a little if the volume is on max.

This stereo is in my 2005 Pontiac G6. Its a stock stereo, I think Delphi.

I cant seem to find any info about this anywhere and I just came across this site. Sorry if this is not the right place for this. Thanks!
What does the Radio look like? I drive an 08' G6 GT.

Does it look like this?
 

Attachments

·
Registered
Joined
·
219 Posts
It similar, mine looks like this. I believe I have Monsoon, no xm.
Yes... that is what mine looked like. I had the 6 disc monsoon stereo. The radio display shows all the vehicles information like fuel mileage and tire pressure and blah blah blah. From what I understand, these stereos are problematic. You may be able to just purchase a used one on eBay or pull that one out and double check the antenna connection to make sure it is secure.

Do you see that button on the side of the volume knob... on the left. Looks like a ramp? That is the auto volume button... make the radio get louder the faster you drive... see what level it is on. I think there are 3 levels and off.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Yes... that is what mine looked like. I had the 6 disc monsoon stereo. The radio display shows all the vehicles information like fuel mileage and tire pressure and blah blah blah. From what I understand, these stereos are problematic. You may be able to just purchase a used one on eBay or pull that one out and double check the antenna connection to make sure it is secure.

Do you see that button on the side of the volume knob... on the left. Looks like a ramp? That is the auto volume button... make the radio get louder the faster you drive... see what level it is on. I think there are 3 levels and off.
Last I checked auto volume was on high. I have checked the antenna at my rear window. If I unhook it nothing happens! I dont even lose reception. The stereo does stop at all the stations and I can hear them clearly when volume is maxed, its just very low like I cant really hear it if I open the windows.

Id rather fix this one than replace it because I would also need to have a new one reprogrammed by the dealer. I have an after market but this car has the DIC in the stock stereo and Im not paying 200 bucks for a metra kit then more money for the dealer to program it. I have repaired this radio before, it had a cd eject problem and needed a new gear.

My problem is I cant find any info on this issue at all to know where to begin to fix it. I would really hate to replace the radio and still have the same issue.
Seems like this is a very rare issue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I noticed last night that my FM does seem to have volume! I tried manually going through stations and on aq lot of them the volume was normal though there was alot of static. But then when I got to one of my local stations the volume was very low but no static.
I dont get it...anyone have any ideas?
 

·
Registered
Joined
·
219 Posts
Last I checked auto volume was on high. I have checked the antenna at my rear window. If I unhook it nothing happens! I dont even lose reception. The stereo does stop at all the stations and I can hear them clearly when volume is maxed, its just very low like I cant really hear it if I open the windows.

Id rather fix this one than replace it because I would also need to have a new one reprogrammed by the dealer. I have an after market but this car has the DIC in the stock stereo and Im not paying 200 bucks for a metra kit then more money for the dealer to program it. I have repaired this radio before, it had a cd eject problem and needed a new gear.

My problem is I cant find any info on this issue at all to know where to begin to fix it. I would really hate to replace the radio and still have the same issue.
Seems like this is a very rare issue.
If I remember it just has to be the same part number... there shouldn't be a programming needed. Mine came from a scrap yard. I just tossed it in and it was fine. It was the same part number though.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
If I remember it just has to be the same part number... there shouldn't be a programming needed. Mine came from a scrap yard. I just tossed it in and it was fine. It was the same part number though.
Most of what I have read says another radio will need to be programmed unless I buy one that is unlocked or you can do a faceplate swap.
I did look in the junkyard though but didnt find any. Unlocked ones are about 150 and locked ones are a bit less than that.
With 175k this is pretty much a beater car and I dont want to spend more than 50 bucks fixing the radio. At this point I still dont know if its the radio, antenna or something else internally like a loose connection that simply needs to be soldered or even a bad switch that needs replacing.
Just wish I could find more answers, been checking all over the net.
 

·
Registered
Joined
·
219 Posts
Most of what I have read says another radio will need to be programmed unless I buy one that is unlocked or you can do a faceplate swap.
I did look in the junkyard though but didnt find any. Unlocked ones are about 150 and locked ones are a bit less than that.
With 175k this is pretty much a beater car and I dont want to spend more than 50 bucks fixing the radio. At this point I still dont know if its the radio, antenna or something else internally like a loose connection that simply needs to be soldered or even a bad switch that needs replacing.
Just wish I could find more answers, been checking all over the net.
I feel ya man... The G6 owners club website doesn't have much info either. I'd be happy to give you my factory head unit. It works, the display occasionally stops working for a few key cycles but it only does it on occasion.
 

·
Registered
Joined
·
1,781 Posts
Some vehicles will have antenna wires that are actually 2 wires that are connected somewhere in the vehicle and can become unplugged. I think the Dodge Neon's had this issue. Try pulling out the radio and disconnecting your antenna, then use either another antenna cable or piece of wire to make contact to the center conductor on the radio side of the antenna to see if you get reception.
 

·
Registered
Joined
·
219 Posts
I am assuming your G6 is a 4 door as mine is a coupe because mu antenna is on the roof, centered above the windshield. It occured to me that you said you have repaired your head unit before which means it has been out of the dash. Since it has been out, pull it out and double check those connections. If it still isn't better, PM me, I will send you my factory Monsoon head unit.
 
1 - 12 of 12 Posts
Top