DiyMobileAudio.com Car Stereo Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
396 Posts
Discussion Starter · #1 ·
I tried searching google and the forums for some info on this with little success. Hello there my name is Jon and this is my first thread here on DIY Mobile Audio. I hope I am welcome here for this looks like a very nice forum :) I recently just purchased an Alpine IDA-X305 last week from Pacific Stereo with 3 Day shipping. Installed it without a hitch finished at night, looked normal at night.

Come next afternoon the screen looks like this:


At night it looks normal, possibly dimmer than most lcd screens, when dimmer is turned on various settings it gets very dim. I snipped the Dimmer wire to see if the factory dimmer settings are lower by default, but it didn't affect it.

Next afternoon on a fairly cloudy day, I used my 6 year old poorly backlit 5th gen IPOD 30GB Video as a reference.


I placed a small flap of paper above the lcd for this shot to shadow it and coax a little more darkness around it.



Is this normal for the IDA-X305? I've read a number of good reviews on this before buying and this is also the third version of this line so you would think there would be more complaints? Should I RMA this and buy another one, and risk the same problem, or settle for the CDA-9886? I have to stick to alpine due to my KTP Power Pack. Any help would be greatly appreciated. I am getting very paranoid about my situation and hope the dealer will be understanding of my situation if I do request a RMA.
 
1 - 1 of 1 Posts
Top