DiyMobileAudio.com Car Stereo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey friends,

Really need your help here. I am a great enthusiast with limited experience in audio. I tried improving my i20 audio with the following

2 pair 3-way sound stream 6/5" (90W RMS)
1 pair oval soundstream (130W RMS)

1 soundstream 4 channel 300W (RMS)
1 mono amp (400W RMS)
1 JBL 275 RMS

After all this, i expected the system to give me blasting music at great quality (i tuned levels to match an even output front and rear)

However, before i replaced the stock speakers with the new ones, i could get excellent Bas. now, it kind of gets lost in the vocals. there is also a lot of distortion (sub) though i have reduced the level for 4 channel amp.

the wiring is done like this:

All four channels via RCA converters to the 4 channel amp from HU
an additional RCA converter on the HU to the mono block (split from rear output from HU). this we had to do after originally using 4 channel amp as source for the mono .

What is to be done? is my money wasted ? I have not replaced the stock HU since i really like the steering controls.

Regards,

Kumar:confused::bigcry:
 

·
Registered
Joined
·
108 Posts
1. You are splitting the signal with a Y cable so sub is not getting enough signal and you probably have to pump up gains which is making sub distort

Which HLA convertor is it ? Also try taking your car to a professional in your city who knows about tuning!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hey many thanks,

Turns out it was the stupid RCA converter, changed it and am back to thumping music.

I will try polyfill today to check if it has an impact on the sub.

K :drummer:
 
1 - 4 of 4 Posts
Top