DiyMobileAudio.com Car Stereo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter #1
I have a Helix P Six with the USB card installed. I was running my iPhone X as a source directly from lightning to camera adapter to USB. This used to work well, and then stopped working. I ordered a new camera adapter, which worked for a day and then stopped too.

Thankfully, I also have a Pure I20 into optical with an old iPod as backup.

Anyone else have this issue? Anything I can troubleshoot?

I've confirmed that there is nothing wrong with the camera adapter. When I plug the adapter into USB on my computer and then plug in the phone, the computer recognizes the phone.
 

·
Registered
Joined
·
1,072 Posts
There’s a known issue with usb hecs and iphones (maybe the update on the camera kit perhaps if it worked for a day and then didn’t? Did it says software update for the camera kit was available and needed to be installed by any chance??) or we suspect ios13.x when something changed in the phones software (my take on it is the digital signing of the hec with the phone/camera kit... but as yet it’s unknown cause...) the hec works with android but that’s a hole heap of fun in itself, the camera kit works fine with a topping d10 and charges fine
 

·
Registered
Joined
·
139 Posts
Discussion Starter #3
Yes, it worked for a day, I updated software on camera kit and then it didn't work. That sucks. Is there a way to fix it?
 

·
Registered
Joined
·
1,072 Posts
T
Yes, it worked for a day, I updated software on camera kit and then it didn't work. That sucks. Is there a way to fix it?
That would make sense... so it may be a camera kit update that’s messing with hecs... sorry I don’t know a solution, but that explains a lot
 

·
Registered
Joined
·
139 Posts
Discussion Starter #5
Do you know if the lighting to USB cable without charging has the same issue? Thanks for your help with this.
 

·
Registered
Joined
·
447 Posts
Perhaps Apple have finally stopped the camera adapter workaround mode for non Apple registered USB audio devices.

The camera adapter was originally the solution as an iPhone wouldn’t power any accessories that advertised a power requirement of more than 140 milliamperes ( from memory so might be wrong)and t so many Dacs couldn’t be useds With the camera kit it advertises itself as a powered source so that would get it around the first issue.

The second issue is that Apple like to licence what USB devices can work with the phone or iPad that use USB audio mode.
Suspect with the camera kit software coding wasn’t smart enough to detect non licensed USB dacs until now.

or they have introduced a bug and stopped a whole bunch of USB devices from working via the vcamers kit.

I had a similar experience with a cheap adaptor and a higimediy ess Sabre 2018 dac which worked for a day and then stopped.

I’d try it again when iOS 14 comes out in the next month or two

Sorry , just saw your mention on power. Do try adding power to the adapter as it could be the first area I mentioned
 

·
Registered
Joined
·
1,072 Posts
Do you know if the lighting to USB cable without charging has the same issue? Thanks for your help with this.
That may work, but I know my topping doesn’t work without charging input... contactless charging may get around that however...
 

·
Registered
Joined
·
139 Posts
Discussion Starter #8
I think I am going to order another camera kit and hope it doesn't have the updated software. Then I will just not update it. Hopefully it works!
 
  • Like
Reactions: dumdum
1 - 8 of 8 Posts
Top