DiyMobileAudio.com Car Stereo Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
96 Posts
Discussion Starter #1
I have a bad channel on my KS 300.4. So I would like to replace it. I am looking for a 300.4 or even a 300.2 will work for my system..
I would prefer if the 300.4 was a V1 (which is a long shot) as that is what I have and the way I have them setup it would look the best. I think the 300.2 V1 is the same size

Might even consider a mono version as well if the sizing is close as I can swap stuff around..

What do you (hopefully) have
 

·
Registered
Joined
·
7 Posts
What are you running with you amp? I have a KS300.2 powering my DLS UP36i set at 4 ohm stereo. Plenty of power and never had any issues with it.
 

·
Premium Member
Joined
·
96 Posts
Discussion Starter #3
I was running a 3-way with a passive crossover.. I switched to active, pair of 6.5" and pair of tweeters and now the one channel does not work.

I Have another 300.4 bridged running a pair of woofers, so I could use that for the fronts and get a 300.2 for the rears.. Love the amps, just bummed the one has a bad channel now.. when it was bridged it seemed to work. net thought is swap the amps and see how that works
 

·
Premium Member
Joined
·
587 Posts
Got one in mint condition.. KS300.2 v2

 

·
Premium Member
Joined
·
96 Posts
Discussion Starter #8
might have my Amp fixed.. seems like a switch might be the problem..

Kenny I need to measure mine to confirm the length I have
 

·
Premium Member
Joined
·
96 Posts
Discussion Starter #10
That is a V1, mine measures the same.. Let me know what you would want for it.. I will know int he next few days if mine is fixed
 

·
Premium Member
Joined
·
96 Posts
Discussion Starter #12
No longer needed thanks to help on the forum all that was needed was Deoxit on the switches


Sent from my iPhone using Tapatalk
 
1 - 12 of 12 Posts
Top