DIYMobileAudio.com Car Stereo Forum banner
1 - 20 of 20 Posts

· Premium Member
Joined
·
872 Posts
Discussion Starter · #1 ·
im looking to get a as 100.4 repaired , anyone know a trustworthy repair shop that is still in business ?
i purchased this amp used from a trusted seller (amp-guru) . waited 3 weeks for it and it shows up down 2 channels

thanks guys !
 

· Registered
2016 Gmc Sierra SLT
Joined
·
207 Posts
Have you spoken to Amp-guru about the issue? I have purchased several items from him and personally know many other who have and have never seen such an issue and was always delivered within 3 days, that's crazy fast from Germany to the US. I did have buddy buy a Helix amp he advertised as new but when it arrived it had a few blemishes. He was very understanding and quick to rectify the situation. I would speak with him before any work is done unless you are determined to keep that particular amplifier.
 

· Registered
Joined
·
2,217 Posts
Orca in Cali is the only authorized mosconi repair facility in North America apparently. Might try giving them a ring but not sure they would repair something they didn't sell. I know they were of no use to me but that's because I'm in Canada. Worth a shot tho. I would definitely contact Amp guru first tho as he's supposed to be a great seller I've heard - even been contemplating grabbing one from him as well (actually might even be the one you have currently lol)
 

· Premium Member
Joined
·
872 Posts
Discussion Starter · #4 ·
Have you spoken to Amp-guru about the issue? I have purchased several items from him and personally know many other who have and have never seen such an issue and was always delivered within 3 days, that's crazy fast from Germany to the US. I did have buddy buy a Helix amp he advertised as new but when it arrived it had a few blemishes. He was very understanding and quick to rectify the situation. I would speak with him before any work is done unless you are determined to keep that particular amplifier.
yes i have , he just kinda blew me off saying its probably a short on one of my speakers or something , there is no issue with my install . the amp goes into protection mode with no speakers attached to it . also i took over 3 weeks to get to me and when i received it it had a loose mosfet clip and 2 wood screws inside the case rattling around . i removed the parts inside before powering it up .
i have a as 200.4 hooked up in its place with no issues , and tested my old genisis amp as well no issues . SOOOOO i think its the amp! for sure at this point just sucks that he wont back up his product .
 

· Registered
2016 Gmc Sierra SLT
Joined
·
207 Posts
I agree it definitely sounds like an issue on his end. Very sorry to hear this about him, as for someone to take a look at it I would recommend @EricsAmplifiers based on many positive reviews on fb.
 
  • Like
Reactions: chasingSQ

· Premium Member
Joined
·
872 Posts
Discussion Starter · #6 ·
I agree it definitely sounds like an issue on his end. Very sorry to hear this about him, as for someone to take a look at it I would recommend @EricsAmplifiers based on many positive reviews on fb.
ok thanks !
 
  • Like
Reactions: OzAudioGmc

· Registered
Joined
·
2,217 Posts
Oh wow. This response you got likely prevents me from trying to get anything from him. Very disappointing.
 
  • Like
Reactions: juvehab

· Premium Member
Joined
·
872 Posts
Discussion Starter · #10 ·
Oh wow. This response you got likely prevents me from trying to get anything from him. Very disappointing.
yeah its a real bummer , i also asked if i could send it back for testing , or if he had anyone in the states that could look at it , no response .
 

· Premium Member
Joined
·
872 Posts
Discussion Starter · #14 ·
Oh wow. This response you got likely prevents me from trying to get anything from him. Very disappointing.
after a few day he reached out to me about a resolution , im glad about that , im sending it to eric for an evaluation
 
  • Like
Reactions: OzAudioGmc

· Registered
Joined
·
2,217 Posts
That's great to hear. I was surprised earlier as this seller has been recommended by quite a few off here. I also have a mosconi that needs help and was going to send to Eric as well (might still) but after the quote I got from UPS yesterday it might not be worth sending. I know Canada Post/USPS is cheaper but I don't currently have a way to box it for shipping to my liking.
 
  • Like
Reactions: chasingSQ

· Premium Member
Joined
·
872 Posts
Discussion Starter · #16 ·
updates ! eric received the amp and was able to repair it and get it back to me super fast ! ,, I highly recommend Eric for repair work . great communication , and a super nice guy
i have sent the repair invoice to the amp guru at his request , ill report back for his efforts to resolve this issue . Ian
 

· Registered
Joined
·
2,217 Posts
Thanks for the update. Great he could repair it quickly for ya. I'm hoping to get mine to him for same if I can find a way to get it to him without killing me on shipping (in in Canada). What was wrong with it anyway?
 

· Premium Member
Joined
·
872 Posts
Discussion Starter · #18 ·
there was a mosfet clip that broke causing a short . and a couple switches in the board that were stuck .
 

· Registered
Joined
·
2,217 Posts
Great it was a straight forward fix. Think mine gonna need a fair amount more
 

· Premium Member
Joined
·
872 Posts
Discussion Starter · #20 ·
UPDATE . the amp is on the way back from repair, and the amp-guru . paid the invoice for repair . its nice that even from overseas, people have integrity and do the right thing ,rare but in this case ill take it .
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top