DiyMobileAudio.com Car Stereo Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter · #1 ·
Ok so i have yet another and very weird problem, and cannot figure out whats going on, i have never read anything similar, so please help. For some reason my left tweeter cannot get loud at all, is it blown? (that would be my only guess that cannot confirm) I was doing some tuning yesterday and everything was fine, my car sounded great, until all of a sudden, i noticed the stage switched to the right and instead of having left center right, i had center right, and it annoyed the crap out of me. Today i have been trying to troubleshoot this but i cant. i switched my left tweeter from channel 3 to channel 4, and that didnt do it, i try switching simbylin cables and nothing. what can i do now? is this a blown tweeter?
 

·
Registered
Joined
·
742 Posts
remove tweeter and check connection. remove tweeter and connect to known good source. switch left and right tweeter amp outputs. switch left and right tweeter amp inputs. what makes you think that the amp is the source of the problem? and what makes you think that the amp is the source of the problem to the point that you would title this thread "Zapco DC hell" ?????
 

·
Registered
Joined
·
2,544 Posts
and what makes you think that the amp is the source of the problem to the point that you would title this thread "Zapco DC hell" ?????
I don't believe this is his first issue with it.

If the tweeter were damaged, I don't think you'd get any sound out of it. You might get a little static, but probably not music. Does it sound fine, just low? If so, it's not the tweeter.
 

·
Registered
Joined
·
322 Posts
Discussion Starter · #4 ·
I do get sound from the left tweeter and it sounds good, no distortion what so ever.
 

·
Registered
Joined
·
322 Posts
Discussion Starter · #5 ·
remove tweeter and check connection. remove tweeter and connect to known good source. switch left and right tweeter amp outputs. switch left and right tweeter amp inputs. what makes you think that the amp is the source of the problem? and what makes you think that the amp is the source of the problem to the point that you would title this thread "Zapco DC hell" ?????
i have had a bunch of issues so far, one time all the channels were muting one at the time and then all came back on, some times i loose my left channel, and now this.
 

·
Registered
2018 VW GTI S VWR springs, DAP spacers, OEM sounds
Joined
·
690 Posts
pm John Sketoe. He had a similar problem with his DCs cutting out.
his forum name is jsketoe on here.
Just do a search and send him a PM.
I think its a voltage problem inside the amp.
 

·
Registered
Joined
·
322 Posts
Discussion Starter · #7 ·
will do a search, thx

what i dont understand it is that no matter what channel i use i have the same issue, and the other tweeter works fine always...
 
1 - 7 of 7 Posts
Top