DiyMobileAudio.com Car Stereo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
316 Posts
Discussion Starter #1
Hi guys -

I just purchased a pair of Morel Elate 9" subwoofers thinking that they'd be perfect... and they're not. :(

I get pretty significant VC rub on one. Other is perfect.

Anybody else experience this with Morel drivers? I did some searching and it seems like this is fairly common for Morel's. Is it because of super tight tolerances or sub-par QC?

I already emailed Peter Moore @ Morel USA so hopefully he can sort me out. Anybody else have a similar experience?

Thanks!

(Mods feel free to move this thread if it's in the wrong section)
 

·
Registered
Joined
·
977 Posts
Fairly common for elates? My friend was a dealer and I don't believe he had any elate 5/6/9 failures. I hear about bad QC on old, like circa late 90's-early 2000's morel, and I think a lot of it had to do with the Morel (Israel) and Morel USA/Renaissance split. Morel USA had some pretty terrible customer service, I know that much.
 

·
Registered
Joined
·
2,322 Posts
It's fair to say that shoddy production quality is par for the course for Morel's cone drivers. Rather shocking, considering the prices they charge, but it is what it is.

Even their SoundSub9 home audio sub - likely a very similar woofer to yours - I bought had the surround partly unglued from the factory. (They did send me a tube of adhesive from Israel to fix it.)

They seem to have their act much more together on tweeters, though.
 

·
Registered
Joined
·
834 Posts
I have some Tempos and love them but, when I needed some customer service help, it was horrible. And, I think it was the same guy. I just finally gave up.
 
1 - 5 of 5 Posts
Top