DiyMobileAudio.com Car Stereo Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Just found out that after hooking it up, testing it before I final the install, that 2 of the 4 channels only work....whatta dissapointment. I bought the unit about a yr and 1/2 ago and just now getting around to it. Had it sitting in my garage ever since. And of course, my fault for not checking it when I first got it just to be sure everything works. Awesome deck, I'm just at a loss right now. Or send it out to get it repaired??
 

·
Registered
Joined
·
16 Posts
i would definitely keep it. i have never used the internal amp on my 9835, only the rca outputs. also, one thing to check would be the 3 way crossover switch on it. than might have something to do with it.
 

·
Registered
Joined
·
671 Posts
I'd definitely keep it, it's a great, versatile, high quality head unit. I believe for a flat fee of $90, you can sent it to Alpine to get repaired good as new.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
I'd definitely keep it, it's a great, versatile, high quality head unit. I believe for a flat fee of $90, you can sent it to Alpine to get repaired good as new.
Really? That's not bad at all. I checked alpines website lastnight and the nearest alpine for me is in CA. Didn't see a email address. Looks like I gotta call them.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
I'm not gonna get rid of it. I'll def get it repaired perhaps later. This is one of the best decks I've owned to date. Have ran Alpine in the past as well as others.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #8 ·
Has anyone had any trouble getting their FM antenna plugged in into the unit itself?? I had to modify something today in order for it to work.
 

·
Registered
Joined
·
130 Posts
Dennis...the antenna should have connected without any trouble. I'll be heading up towards your way next weekend. Want me to stop by and take a look at your deck?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #10 ·
Sure Chris. Need your help anyway for the time alignment. I know your good at it. I got the deck installed. Somehow the FM antenna coming from my factory area doesn't fit in the FM plug on the back of the unit itself. Found it very odd so had to modify it a bit. Also installed a new stereo in Rose's van!!!! She even let me!!!!
 

·
Registered
Joined
·
465 Posts
Another thing, if you have a tahoe with a bose system you might not have anythign wrong with the headunit.
Some of those use an amp for front stage, what year tahoe?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #17 ·
Well, spent 13 bucks on a antenna adaptor. Wish I would have known this before but oh well. Fierce, scroll up to see what yr. Tahoe I got. It doesn't have a Bose system.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #19 ·
Nope, this is the Tahoe's first one. And got the antenna adaptor installed....which did the trick. Thanx fellas for the help.
 
1 - 20 of 24 Posts
Top