DiyMobileAudio.com Car Stereo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
Just bought an arc 1200.6 on Ebay that had 2 broken channels and the JAD800.4's are discontinued... so that sucks.

Looking for 2 of the same 4 channels amp w/ 100 watt/ch or more
or
an Arc 1200.6

I'm in Oregon if pickup is an option.


Thanks.
 

·
Registered
Joined
·
127 Posts
Just bought an arc 1200.6 on Ebay that had 2 broken channels and the JAD800.4's are discontinued... so that sucks.

Looking for 2 of the same 4 channels amp w/ 100 watt/ch or more
or
an Arc 1200.6

I'm in Oregon if pickup is an option.


Thanks.
My arc 1200.6 I just bought on eBay has two broken channels as well. I’ve been trying to diagnose it for about a week and the problem has gotten worse and I’ve just narrowed it down to the amplifier channels five and six. What seller did you buy your amplifier from on eBay?

at first mine was very low volume on the channels and now the two channels are making a weird feedback noise like there is a microphone hooked up to them. I have a very short ground wire and it continues to do it even when I turn the output to those two channels off on my headunit so the amp is just creating the weird noises on those two channel’s intermittently and it’s LOUD when it happens.like my sub sounds like it’s blowing a hurricane wind sound...
 

·
Registered
Joined
·
102 Posts
Discussion Starter #9
My arc 1200.6 I just bought on eBay has two broken channels as well. I’ve been trying to diagnose it for about a week and the problem has gotten worse and I’ve just narrowed it down to the amplifier channels five and six. What seller did you buy your amplifier from on eBay?

at first mine was very low volume on the channels and now the two channels are making a weird feedback noise like there is a microphone hooked up to them. I have a very short ground wire and it continues to do it even when I turn the output to those two channels off on my headunit so the amp is just creating the weird noises on those two channel’s intermittently and it’s LOUD when it happens.like my sub sounds like it’s blowing a hurricane wind sound...
Bought from audiointensity. Tested the amp and channels 3 and 4 just produced static. Nothing else. Was messaging with another guy on forum
@Blue_Horseshoe may have bought the same amp on Ebay. Not sure if he's had the same problems.
 

·
Registered
Joined
·
127 Posts
Bought from audiointensity. Tested the amp and channels 3 and 4 just produced static. Nothing else. Was messaging with another guy on forum
@Blue_Horseshoe may have bought the same amp on Ebay. Not sure if he's had the same problems.

Yup, same seller as mine. I dont know if he did it on purpose, because mine is an intermittent problem, but is hella suspect that multiple amps from the same guy listed as "ex demos" have similar issues. I bet they are returns or b stock from an auction, i doubt refurbs because they look clean, pretty new, or at least mine did.
 

·
Registered
Joined
·
279 Posts
Yup, same seller as mine. I dont know if he did it on purpose, because mine is an intermittent problem, but is hella suspect that multiple amps from the same guy listed as "ex demos" have similar issues. I bet they are returns or b stock from an auction, i doubt refurbs because they look clean, pretty new, or at least mine did.
Bought from audiointensity. Tested the amp and channels 3 and 4 just produced static. Nothing else. Was messaging with another guy on forum
@Blue_Horseshoe may have bought the same amp on Ebay. Not sure if he's had the same problems.
wow what a coincidence can't believe this happened to you both!


DM me i have a 1200.6 that works flawlessly.
 

·
Registered
Joined
·
20 Posts
I tested mine yesterday and it appears to be working correctly, though I admit the test was a simple tone test with a single small speaker. I am concerned additional problems may manifest later on.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #13
I tested mine yesterday and it appears to be working correctly, though I admit the test was a simple tone test with a single small speaker. I am concerned additional problems may manifest later on.
You mentioned it was from a different seller though right? Hope yours works.
 

·
Registered
Joined
·
194 Posts
Hello

I have two used arc XDI 600.4 That I can sell you shipped for $550. They are in very good condition on original box.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #15
Hey darinof,
Thanks for the offer, but actually already found a couple amps.

Sorry, I'll change the whole title.
 
1 - 15 of 15 Posts
Top