DiyMobileAudio.com Car Stereo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
My RE Audio 12 SEx D4 has played its last tune. Not sure what happened, but a tinsel lead came loose where you plug in your leads from the inside of the box, so I soldered it back on. Came loose a second time and tried again - this time is was VERY sturdy connection. Sub worked for a bit then stopped. Figured it came loose again, but it had not. Also the sub seemed to be working fine despite the fact it had not been the day before. Took sub out and to my surprise it was still connected. Sub powered up so I had it on the whole time I installed it back in the enclosure - all good. Took it for a drive and it stopped working again. Came home, and out of frustration I pushed the cone down slightly and it came back on.

Either way, no warranty, and seems to be outside the scope of a repair. Things are tight right now, so looking for recommendations for a decent sub within the $120-$150 range that would work with 210w at 4ohm (420 @ 2), and a sealed 1.1 c. ft. enclosure in the trunk of a Civic sedan.

Thanks in advance...
 

·
Registered
Joined
·
118 Posts
Discussion Starter #3
Thanks.

Been looking at the Fi X 12 as well.

Any thoughts on the Fi X vs SSA DCON question? They seem very similar. Is there a clear winner here?

Price difference is negligible. Fi seems to have a shorter build time (thats a plus!).

It it makes any difference, I listen to all types of music. Mostly rock though...
 

·
Registered
Joined
·
118 Posts
Discussion Starter #4
Went with the Fi model. Oddly enough, the RE seems to be working fine the last few days...

Thanks
 

·
Registered
Joined
·
118 Posts
Discussion Starter #5
Posting regarding Fi Car Audio's customer service. Part of my purchasing decision was the fact that SSA had a 7-12 day build time, vs 3-7 for Fi. This is the 10th business day, and still no final word from Fi about when it will be done and shipped.

In addition to completely posting misleading information about their production capabilities, they create the UPS shipper as soon as you ordered is processed, so I have been sitting on a tracking number for over 2 weeks and there has been no change in status to it.

Lastly, their email responses have not been super timely. I requested to know status on the 8th business day, last Friday and got no response until end of day the 9th day, Monday (after a 2nd email Monday afternoon). They then told me the sub was completed the previous Friday and should be shipping that day, and that they would provide an updated ETA based on the tracking number, IN THE MORNING.

Its now after 5pm PT and I have yet to receive the update that was promised. There has been no update on the Fi order status page I was provided, nor was there an updated shipping status in UPS.

I am in a service business and my motto for my clients, vendors, bosses, is "no surprises." I keep everyone informed and am proactive, no reactive.

The advised me they fell behind because of their volume. They should change their BRIGHT RED "standard 3-7 days build time" to whatever their volume dictates it should be as to not promote something that they cannot stick to...

Upset to say the least....maybe standards are too high...
 
1 - 5 of 5 Posts
Top