DIYMobileAudio.com Car Stereo Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
2,595 Posts
Discussion Starter · #1 ·
Well after i finished installing my Midbasses and putting my tweets in some makeshift positions in my car it sounds absolutely fantastic...with the added sub that is (noticed something was missing without it). And the midbass is GREAT i just need even more than i have. Right now my crossover points are looking like sub - 60hz 12db, midbass - 60hz 18db up to 2.5k-3k 12db and tweet from 2.5k-3k 12db (old HE2 12 is being used right now till i build my box for the Tempest). As far as the instillation goes the door is completely deadened inside and out 2 additional outter layers behind midbasses and a layer of ensolite on the 2 additional outter layers, ensolite on complete inner door panel above deadener. The car sounds awesome cept a few things here and there i wish i had different (new HU) and right now it looks like crap.....amps and all on a piece of plywood in the rear till i build my box to mount them on. But how can i get just a little more midbass out of the drivers as i've heard the midbass is supposed to be really good from them, and it is...i just think i'm not getting out of them as much as i could.

PS i still need to mess around more with phasing and such, to get a very good center image, but the only problem is i can't hardly recognize a center image at all.....is it just me or is it a fxn of my stock HU?

Any ideas?
 

· Registered
Joined
·
2,595 Posts
Discussion Starter · #3 ·
So what would you suggest to fix the kick i should be getting......The car is really deep....i mean it sounds awesome, but would just like more in the midbass region...not even sure what frequencies i'm lacking in....gonna burn a 20-20k hz sweep and try tommorrow to see.
 

· Registered
Joined
·
2,595 Posts
Discussion Starter · #5 ·
Yea i tried that, i need to double check it thought, as i remember Awhile back before i took the sub out first time, that i had to mess with the phase on the amp to get it to blend right before......i had to use the 180 switch on my active DX-28 to make it sound right with the new stuff so mabey it could be both the amp and crossover mixing the phasing and all......
 

· Registered
Joined
·
2,595 Posts
Discussion Starter · #7 ·
Panel isin't on it yet....car is basically still completely gutted cept front carpet, center console and driver and pas. seats (dash).....rear is out...door panels off, a-pillar panels off....and such.
 

· Registered
Joined
·
2,595 Posts
Discussion Starter · #9 ·
I will be putting my tempest into the car as soon as i get a box built for it, as of now the sub is my old RF HE2 12. I have the Seas IB in my front doors, i want as much bass up front as possible....tommorrow i'll check out a few different xover points and such, and we'll see what happens from there. Going to start building my sub box here in a few days so hopefully the Tempest will be going in soon after that. I will be having one hell of a wierd shaped box so it may take quite awhile. Parts of it will be f-glass others MDF.
 

· Registered
Joined
·
2,595 Posts
Discussion Starter · #12 ·
Yea i'm going to be burning a complete test cd basically i just need to find all of the files i want, and phasing and such as well.

BTW doors are already completely sealed as in IB. except as of right now a few plastic panel holder thingys that hold the door panel on...those are the only holes as of now.
 

· Registered
Joined
·
2,595 Posts
Discussion Starter · #13 ·
Messing around with my sub/midbass integration today i got it pretty nice for SQ music and such, as for rap it sucks, but i don't listen to it that much. But today i also noticed that one reason my midbass could also be lacking is the fact that my Stock HU has built in EQ curves for the old speakers, slight EQ curves that i've manipulated with the treb and bass settings on the HU to try to audibly make it sound as flat as possible...but still isint really enough, but i've noticed that there is a bump in my midrange frequencies which could be the reason why my midbass may be lacking its umph like i had been looking for. Will try to get a new HU as soon as possible, (wanting a 8053 extreemly bad) but i doubt i will be able to get any new equip any time soon. which sucks, as my parents still have a say in what i can and can't spend my money on, as i'm still living with them and going to school. But as of now it sounds fantastic as is.....but theres still TONS of room for improvement.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top