DiyMobileAudio.com Car Stereo Forum banner

1 - 20 of 57 Posts

·
Registered
Joined
·
5,234 Posts
Discussion Starter #1
Today is the day of the So Cal meet. I get my car cleaned up, the system tuned last night and I get in this morning to leave town. No subs. I haven't touched a thing since yesterday and everything was working fine last night. I figure it's something simple. Oh F**k no! After troubleshooting, the piece of **** HD900/5 lost the sub channel. What a son of a ***** ****ed up piece of **** it is. I'm done with this **** no more for me. Expect a big for sale ad in the classifieds.
 

·
Registered
Joined
·
62 Posts
I hear you brother! I am having issues too. Sleep on first before the big yard sale!
 

·
Registered
Joined
·
5,650 Posts
Nooooo, don't give up you know what doesn't kill you makes you stronger. Plus isn't your amp still under warranty?
 

·
Registered
Joined
·
5,234 Posts
Discussion Starter #5
I'm cursed when it comes to this stuff. The last meet, the MS8 went crazy. This time I drop a sub channel overnight.

When I used to go racing all the time I ended up running many 12 and 13 second passes because my car always screwed up on the way to the track. I could run it for months on the street, always ran great. On the way to the track 90% of the time something would screw up, a burned plug wire, failing fuel pump, blown intercooler hose, you name it, it happened. After a while I learned to just turn around and go home and save the embarrassment.

This is the second JL amp that's failed on me. It's one of the only things I bought used as well so no warranty. I was about to buy the Esotar 110 tweeters but this just saved me over a grand. I'm not putting another penny into this hobby. I've had much better luck from the cheap **** I used to run.
 

·
Registered
Joined
·
156 Posts
I'm cursed when it comes to this stuff. The last meet, the MS8 went crazy. This time I drop a sub channel overnight.

When I used to go racing all the time I ended up running many 12 and 13 second passes because my car always screwed up on the way to the track. I could run it for months on the street, always ran great. On the way to the track 90% of the time something would screw up, a burned plug wire, failing fuel pump, blown intercooler hose, you name it, it happened. After a while I learned to just turn around and go home and save the embarrassment.

This is the second JL amp that's failed on me. It's one of the only things I bought used as well so no warranty. I was about to buy the Esotar 110 tweeters but this just saved me over a grand. I'm not putting another penny into this hobby. I've had much better luck from the cheap **** I used to run.
I think we all understand your frustration and have all been there. I know I've taken the KISS approach and have reduced my system to about the minimum. Keeping it simple has also kept me from many of the past issues and failures. Again, sorry to hear about your amp issue.

My buddy just dumped his HD 900/5 a few weeks ago 'cause 2 of the channels stopped working, both at the same time.
 

·
Registered
Joined
·
5,650 Posts
I know the feeling as I used to have show cars that would the day of the show rear its ugly head. I had gotten to the point where I just sold everything at a loss just to get out. Now I am on the audio kick and my problem lies in the fact of too much equipment, not enough cars. I am selling all of my current equipment as a bundle just to get rid of it $1000.00 takes all of it.
 

·
Registered
Joined
·
2,502 Posts
u can still go to the meet. check out other cars. have someone else look at ur setup see if they see the problem
 

·
Registered
Joined
·
5,234 Posts
Discussion Starter #9
I think we all understand your frustration and have all been there. I know I've taken the KISS approach and have reduced my system to about the minimum. Keeping it simple has also kept me from many of the past issues and failures. Again, sorry to hear about your amp issue.

My buddy just dumped his HD 900/5 a few weeks ago 'cause 2 of the channels stopped working, both at the same time.
My last JL amp did the same thing. It dropped every channel one at a time over 6 months. I have another sub amp but if this is anything like before, the other 4 channels are going to follow shortly. It's not worth the stress over something as simple as car audio. I'm beyond pissed, I'm surprised my car didn't end up with several dents in it. I've got better things to do with my time and money than this.
 

·
Registered
Joined
·
5,234 Posts
Discussion Starter #11
u can still go to the meet. check out other cars. have someone else look at ur setup see if they see the problem
I wouldn't be so mad if I weren't sure it was the amp. I can plug the subs into any of the mids or midbass channels and they work fine. I can plug the sub RCA inputs into the other channels and they work fine. It's the amp unfortunately. Someone is going to get a great deal on this stuff, I might just put it toward the down payment on the new ZL1 Camaro in a few months.
 

·
Registered
Joined
·
5,650 Posts
That new camaro is going to be a beast even as stock.
 

·
Registered
Joined
·
5,234 Posts
Discussion Starter #14
That new camaro is going to be a beast even as stock.
And a pulley, exhaust, and intake later and you're looking at some serious hp.....with a warranty.

As for the audio stuff, I might as well break it up, I've received enough PMs that I think everything is nearly accounted for. Going to run this by a few friends to see if they want dibs on any of it and then I'm making the ad.
 

·
Registered
Joined
·
5,830 Posts
Damn I am sorry to hear your audio troubles, that JL HD900/5 may be repairable...all I can say is that interest in the hobby comes and goes as priorities rearrange and come full circle. Good luck with everything man!
 

·
Registered
Joined
·
5,234 Posts
Discussion Starter #16
Damn I am sorry to hear your audio troubles, that JL HD900/5 may be repairable...all I can say is that interest in the hobby comes and goes as priorities rearrange and come full circle. Good luck with everything man!
That's partially what's going on as well. I've been trying to do a system that will sound great that I can leave alone and be happy with for the next few years in preparation for blowing my money on a wedding and eventually kids. I was basically trying to get this all out of the way real quick but stuff keeps breaking and I finally realize there's no such thing as leaving it alone for one reason or another.

On a different topic, all I can say is the E650 sounds absolutely amazing when running subless. I'm *almost* satisfied with it without the subs.
 

·
Moderator
Joined
·
18,604 Posts
I was planning on about $600 but we can talk.
lol.


In all seriousness, man, you're preaching to the choir here. I've had so many fail moments that have made me want to quit. I've "quit" being a tester a few times in the past year... I just needed a break from this ****. It's nice to be able to walk away and come back when you want. You have that luxury. Take advantage of it. If you want someone to keep the Dyns warm for you, give me a call. :D
 

·
Registered
Joined
·
5,650 Posts
Well you know as soon as you post, we will buy it all. When I sell all the rest of my equipment, I'm just going to do up my Ram and call it quits.
 

·
Registered
Joined
·
5,650 Posts
My Legacy will continue to be built up, but I refuse to tear into my Ram. I figure if I concentrate on the power part of the Ram, that should keep me poor enough not to be able to afford the audio part. Lol...
 
1 - 20 of 57 Posts
Top