DiyMobileAudio.com Car Stereo Forum banner

1 - 20 of 22 Posts

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #1
Let me know what you got? In need of basically a Parts or Donor Unit but will consider any Confirmed working Units.
 
  • Like
Reactions: mark3004

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #2
Bump
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #3
Bump
 

·
Registered
Joined
·
64 Posts
Hi I actually have two at a repair shop now. One grey (which I will keep) and the other painted gold. They are repairing the grey one, but have not started on the gold one yet.
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #5
Hi I actually have two at a repair shop now. One grey (which I will keep) and the other painted gold. They are repairing the grey one, but have not started on the gold one yet.
So who did you send yours to?
 

·
Registered
Joined
·
64 Posts
I let a local shop take care of it this time; Atlas Electronics in Dallas. Usually my amps to to Ray Rayfield (TIPS, Linear Power) or Jeff Priddy an independent repair guy with good credentials. Priddy recapped my Zapco ck2 and McIntosh amp. Atlas actually just called me this morning and said that amp was ready. When I took it in, it powered up bad had horrible sound out of all the channels. I can let you know how it sounds when I pick it up. If its good, I'll have them repair the other.

Just realized one important thing. I have M860's not 860MX's
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #7
Yes please do. Jeff is about the most knowledgeable Tech I know of, been dealing with him for years. I'm about 90% sure I have issues with the N and P J-Fets maybe the Large Toshiba Fets as well. They are NLA thus the thread I started. Let me know what all they had to replace on yours if you can. Probably just Cap related.
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #8
Bump
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #9
Bump
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #10
Bump
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #12
I'm hoping my issues are with the switching mosfets for the power supply. That's an easy fix I believe as these parts are obtainable. What makes this amifier difficult is its what I believe to be one of the last revisions as the board is slightly different than my other two.
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #14
They still have my 860mx. I wanted to test the m860 before I gave them the go ahead to fix this amp
I'd be curious as to what revision your board is! Mine is Revision D. It also has some Resistors that have been cut out of circuit, unlike the other two 860mx I have.
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #15
Bump
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #16
Bump
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #17
Bump!
 

·
Premium Member
Joined
·
1,128 Posts
Discussion Starter #19

·
Registered
Joined
·
3 Posts
Yes, I've seen the 850MX. Unfortunately it's circuitry design is very different than that of the 860mx.
The guy with the 850 is only a half hour from me and had me tempted enough to buy the schematic for the amp to see how it's put together. The signal processing is straightforward but the amp section is baffling to me. Is the 860 simpler?
 
1 - 20 of 22 Posts
Top